バッテラが如く

プログラミングしましょ!

【Flutter】Minimum supported Gradle version is x.x.x. Current version is x.x. If using the gradle wrapperというエラーが出た件について (AndroidStudio)

環境構築中にワーニングを消す作業をしたら次は表題のエラーが出ました。

ということでこのエラーに立ち向かう記事です。理解できていないことも多いため間違ってる事言ってるかもしれませんが悪しからず。

※この記事の情報は次のバージョンで動作確認しています。

  • MacOS Monterey (12.1) Flutter (v2.10.4) VSCode (v1.67.2)
  • 原因

    Minimum supported Gradle version is 7.3.3. Current version is 6.7.

    人によってこの数値は違うと思いますが、7.3.3 が最低なのに、あなたは 6.7 になってまっせということです。

    Gradleのバージョンを上げればいいよというものです。

    一応エラーの続きを確認すると、

    /android/gradle/wrapper/gradle-wrapper.properties to gradle-7.3.3-all.zip

    この通りに直してあげましょうという話です。

    解決策

    gradle-wrapper.propertiesを開きます

    黄色枠の部分の数値をエラーに載ってた数値に変えてあげます。

    変えたらビルドしてみましょー。

    おわりに

    最後まで見ていただきヘペトナス!

    読者登録・Twitterのフォローもお願いします。